[FreeBSD]Need Help - BSD

Users browsing this thread: 1 Guest(s)
Long time nixers
Okay so I rather not completely reinstall my system, and I know this was a somewhat common problem involving update pcre...well I've tried portmaster -r pcre, still nothing. I am currently compiling libchk to try that option, can someone give me some other options?
Shared object "libpcre.so.1" not found
Following "found, comes any program with a pcre dependency, for most of you that know that's damn near every application -_-

LDconfig output:
~ sudo ldconfig -r | grep pcre
        252:-lpcre.3 => /usr/local/lib/libpcre.so.3
        253:-lpcre16.2 => /usr/local/lib/libpcre16.so.2
        403:-lpcre32.0 => /usr/local/lib/libpcre32.so.0
        404:-lpcreposix.0 => /usr/local/lib/libpcreposix.so.0
        405:-lpcrecpp.0 => /usr/local/lib/libpcrecpp.so.0
Long time nixers
Closing, fixed it. Deinstalled the updated version of pcre and just reinstalled the backup that portmaster made, then properly upgraded with portmaster -w. welp.

Edit: Forgot im not cool enough to close my own threads, whoever sees this thats cool enough for the turtle club can close this.
Grey Hair Nixers
Ahah the classic pcre error :) it's been a year or so since I got it though.
Long time nixers
Yeah I was stumped for a moment xD