[FreeBSD] Setting up pkgng - BSD
Users browsing this thread: 1 Guest(s)
|
|||
Pkg 1.0 is out now! The betas and RCs are over, say hello to the first release!
You may, or may not have heard of the introduction of FreeBSD's new package manager, which is a huge improvement of the old pkg-* tools. What is pkgng? Quote:pkgng is: INSTALLING: To install pkgng, you can install directly from the ports tree: Code: cd /usr/ports/ports-mgmt/pkg; make install clean Once installed, you'll need to setup the config. Code: mv /usr/local/etc/pkg.conf.sample /usr/local/etc/pkg.conf the config won't need any editing, it already has a repo setup for it now. REPO UPDATE: To update the repo. PHP Code: pkg update If you've been installing from ports or using the old pkg-* tools. You should register all installed packages in the new database. PACKAGE REGISTRATION: Code: sudo /usr/local/sbin/pkg2ng This may take awhile depending on how many packages you have installed. PACKAGE SEARCHING: Code: pkg search packagesname PHP Code: [amzo@Bahamut ~]$ pkg search slim PACKAGE INSTALLATION: Code: sudo pkg install packagename PHP Code: [amzo@Bahamut ~]$ sudo pkg install slim READING PKGUPDATING: It is still recommended to read updating when upgrading ports, to solve issues. PHP Code: pkg updating pkg-config PHP Code: sudo pkg set -o devel/pkg-config:devel/pkgconf PHP Code: sudo pkg install -f devel/pkgconf VERSION CHECKING: PHP Code: pkg version UPGRADING: PHP Code: sudo pkg upgrade I removed loads of package names from the list, the size needed to download is correct. :p DELETE PACKAGES: NOTE: WILL UPDATE AND COLORISE IN AN HOUR OR SO, GOTTA GO OUT so just posting what I've done so far. Screw saving drafts. |
|||
|
|||
I also book marked and will use a bit later! Thanks!
I do Byte
|
|||
|
|||
I don't have a "pkg" directory under /usr/ports/ports-mgmt/
When I cd /usr/ports/ports-mgmt/pkg I get an error: "No such file or directory." I'm using FreeBSD 9 RELEASE What dumb mistake am I making? |
|||
|
|||
|
|||
(19-10-2012, 03:07 PM)NeoTerra Wrote:(19-10-2012, 08:55 AM)29a Wrote: I don't have a "pkg" directory under /usr/ports/ports-mgmt/ Nope... I have no "pkg" subdirectory under "/usr/ports/ports-mgmt/" |
|||
|
|||
(19-10-2012, 07:11 PM)29a Wrote:(19-10-2012, 03:07 PM)NeoTerra Wrote:(19-10-2012, 08:55 AM)29a Wrote: I don't have a "pkg" directory under /usr/ports/ports-mgmt/ then... you haven't updated your local ports tree portsnap fetch update or if you've never done it before, more likely portsnap fetch extract Since I haven't seen it mentioned already, you're going to have problems with whatever tool you're used to using for compiling and upgrading ports (for me it was portmaster) unless you cd /usr/ports/ports-mgmt/portmaster make deinstall clean make config make install and enable the PKGNG patch in the config step. |
|||