[Solved] Weird Problem With My Wireless Network - Desktop Customization & Workflow

Users browsing this thread: 1 Guest(s)
Hello fellow *nixer,
I've been having a really strange problem with my connection for about 3 months now.
I cannot access HTTP (port 80) when my brother is browsing internet on his Ipad3 but I can access everything else including https. However, the last one is way slower.
Other *nix cannot access HTTP (port 80) when I am connected to the router.
Seems like a conflict when machine running a unix-like OS are connected to the router.
Maybe a jamming issue, a collision issues?
I've searched a lot but didn't find any solution so far.(other then to shout at my brother while he's browsing on his ipad jamming all my connection)
When I'm using proxy (other port then 80), the connection seems to be fine.

Let's summarize what I've tried so far:
-setting different DNS on each *nix
-spliting the network in 2 using subnet mask
-setting the ipad to use bootp instead of dhcp
-changing my dhcp client to dhclient
-changing my wireless driver (wicd) to nl80211
-changing the router IPv6 configs to local-only or 6to4
-putting my machine onlone in a dmz
-changing the TCP/UDP endpoints
-changing browser (ipad and comp)
-using another interface
-disabling iptables

wireshark didn't really help. From what I debugged it seems as if when another *nix machine ask the router for something my machine becomes in congestion mode for the port 80. The router logs didn't show something specific nor did wireshark.
When the ipad is browser suddenly the packet sent are waiting: wireshark just barelly show packet when the ipad is connected and I'm requesting a tcp connection to a website.

EDIT: Problem solved when using /bin/ip instead of wicd.

Suggest me some smart ideas, I'll try them and see if it solves something.
Thank you!
I own a dlink dir-615 C1.
My brother is already on static IP.
I also already tried to put him in his own subnet and it didn't change anything.
The MAC filtering is turned off.
I also think that it is not a machine issue because I'm not having this problem when I connect to other networks.
I was reading about dd-wrt today but I'm not sure about replacing my router firmware with it .
Thanks a lot NeoTerra.