mail: sendmail - Old school stuff

Users browsing this thread: 1 Guest(s)
i just installed sendmail into slackware (14 - i386) and it was working until the other day... i'm constantly changing place, there is 2 different networks im connecting at university (one is for students other is national academic network) and they have different restrictions.

im connecting 1 and constant network in my home

and when im on my way, connecting through 3G / mobile

actually i dont remember exact times and locations but i have sent a mail successfully to hotmail from student network
i have successfully sent mail to gmail (and not a spam) from home
i might had success on mobile connection... bluetooth tethering

then i came home last saturday and that 'sending' function was gone... it left No route to host behind...

so i dig into it and found out port 25 is disabled in my home isp so i started to look an alternative... i have an droplet (debian 7) and installed sendmail to it (digitalocean)
and i successfully sended mail to gmail, also with masquerade, i managed to add some valid hostname ( - linked to this netbook) so mails not dropping to spam.

first i thought if i just change the port im using and redirecting that mail from droplet i can send my messages... also i can recieve messages too bacause the fqdn is linked to my laptop and im sending that fqdn from vps

then i failed doing this but find some documentation about relaying gmail smtp server so i decided to try it (my own mail addr) but failed that too...
first relay try failed with auth error and second one was ssl error or an refused connection because ssl.

then tried to use tor but its failed too... so i went back to changing ports then i found i can make it use 587 or 465... these were not blocked here so worked on 587...
tried many combinations, setting daemon to listen these ports, disabling ssl etc.
none of them worked... if i disable my own port 25, i get connection refused [] error in the first place without sending mail...
if i set 25 on and others on it tries to send mail through 25

i also noticed that has ipv6 addr and because of that it may not find its way so i tried adding it to hosts with ipv4 addr and disabling ipv6 from kernel and blacklisting it in /etc/modprobe.d (ipv6.disable=1 in kernel)

relay with vps
        / <== mail send and status message return ==> vps == send only ==>
nettop |
        \ <== == == recv only...
note: i tried smart-host for relaying... both relay:[ip-addr] and just [ip-addr]

im desperate... :/
Slax 7.0.8 (32-bits + PAE)
Version: 3.1
GE/CS/CM/S d+@ s-:- a--- C++++(++) UL+++ P+ L+++ E?() W+++(++) N? o? K- w+
O M-- V- PS+ PE Y? PGP- t+ 5? X++++(+++) R- !tv b+ DI? D- G e- h+ r-- z--