[slackware]libsoup/glib2.26.1 issue - GNU/Linux
klr
Hi, I'm currently trying to install webkit on my slackware64 fresh minimal install. It requires icu4c and libsoup. I have install icu4c. But now when I try to install libsoup it complains about glib not being installed:
Code:
checking for GLIB - version >= 2.21.3... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error: GLIB 2.21.3 or later is required to build libsoup
But, it's installed. I installed GLIB 2.26.1 from source which I optained from gnomes website.

Can someone please help me, I've searched on the www to try find a solution all day. Is it that I need an older or maybe newer version of GLIB? The libsoup I'm trying to install is libsoup-2.32.2 from slackbuilds.com.

Thanks.
arch || dwm || urxvt || mksh || nano
simon
klr
Not really, I don't think that is an issue on Slackware. Thanks for trying to help though.
arch || dwm || urxvt || mksh || nano
Alexander
"This usually means GLIB is incorrectly installed".
Have you tried reinstalling it?
klr
I've installed it, I first tried latest but it didn't want to compile, GLIB 2.21.3 compiled though. I'll uninstall it and see if I can find a package instead.
arch || dwm || urxvt || mksh || nano




Members  |  Stats  |  Night Mode