[Script] Fix vmware ''after'' installation issues [Fix] - General Shell Scripting
EmperorDAZ
After the installation of Vmware workstation, when I run apt-get install <PACKAGENAME> it would give me these errors:

Code:
root@debian:~# apt-get install <somethinghere>
The following NEW packages will be installed:
  <somethinghere>
0 packages upgraded, 1 newly installed, 0 to remove and 15 not upgraded.
Need to get 0 B/1,248 kB of archives. After unpacking 6,966 kB will be used.
Selecting previously unselected package <somethinghere.
(Reading database ... 131007 files and directories currently installed.)
Unpacking <somethinghere> (from .../<somethinghere>.deb) ...
insserv: warning: script 'K01vmware' missing LSB tags and overrides
insserv: warning: script 'S50vmware-USBArbitrator' missing LSB tags and overrides
insserv: warning: script 'vmware-USBArbitrator' missing LSB tags and overrides
insserv: warning: script 'vmware' missing LSB tags and overrides
insserv: Starting vmware-USBArbitrator depends on rmnologin and therefore on system facility `$all' which can not be true!

After searching for a bit on the internet, I have found a fix for this. Here's a simple bash script for the effect
(Alternatively, you can download it here if you are lazy: http://cur.lv/3cui)

Code:
#!/bin/bash

#Fix for vmware installation related errors
#Example: insserv: warning: script 'vmware' missing LSB tags and overrides
#               insserv: Starting vmware-USBArbitrator depends on rmnologin and therefore on system facility `$all' which can not be true!
# Make sure only root can run this script
if [ "$(id -u)" != "0" ]; then
   echo "This script must be run as root" 1>&2
   exit 1
fi
#Fix vmware-USBArbitrator
echo -e "### BEGIN INIT INFO\n# Provides:          vmware-USBArbitrator\n# Required-Start:    \$remote_fs \$syslog vmware\n# Required-Stop:     \$remote_fs \$syslog vmware\n# Default-Start:     2 3 5\n# Default-Stop:      2 3 5\n# Short-Description: Start daemon when vmware starts\n# Description:       Enable service provided by daemon.\n### END INIT INFO" >> /etc/insserv/overrides/vmware-USBArbitrator
chmod 755 /etc/insserv/overrides/vmware-USBArbitrator
#Fix vmware (vmware VMX service)
echo -e "### BEGIN INIT INFO\n# Provides:          vmware\n# Required-Start:    \$remote_fs \$syslog\n# Required-Stop:     \$remote_fs \$syslog\n# Default-Start:     2 3 5\n# Default-Stop:      2 3 5\n# Short-Description: VMware VMX service for virtual machines\n# Description:       Allows running of VMware virtual machines.                                    \n### END INIT INFO" >> /etc/insserv/overrides/vmware
chmod 755 /etc/insserv/overrides/vmware




Members  |  Stats  |  Night Mode