Fixing the forums - Community & Forums Related Discussions
venam
Hello fellow nixers,
This thread is for a log of things that needs to be fixed on the forums (layout, css, etc..) or new ways of organizing them.

As you've probably noticed, I've forced the default black theme unto all users. If you still want the white one back you can change it in the user CP.

Post in this thread any layout/style problem. It'll be appreciated if you can attach a screenshot.
z3bra
Good idea venam !

The biggest issue I have with the forum is the minimum width. 850px is way too wide... Here is a screenie:
http://i.imgur.com/C863ZUI.png

I know that making the forum tigher will brought some new issues, so I could give a hand if needed.
venam
(06-02-2015, 08:58 AM)z3bra Wrote: Good idea venam !

The biggest issue I have with the forum is the minimum width. 850px is way too wide... Here is a screenie:
http://i.imgur.com/C863ZUI.png

I know that making the forum tigher will brought some new issues, so I could give a hand if needed.
I've fixed this.
z3bra
Cool ! many thanks !
z3bra
As I would have expected, I found a few bugs due to the new width.. The first one occurs with inline images:
http://i.imgur.com/NAt3CcP.png

I had it fixed by using this in the global.css :
Code:
.post_body > * > img {
    max-width: 100% !important;
}

the second one as to do with the navigation bars. When the width goes below a specific width, they start to mess up (because they're in
Code:
float: right
). See the following shot:

http://i.imgur.com/BKHjFmG.png

the only fix hack I found was to reduce the font size, so that the bug only appear when the browser reach a ridiculous width ^^'
venam
(06-02-2015, 09:14 PM)z3bra Wrote: As I would have expected, I found a few bugs due to the new width.. The first one occurs with inline images:
http://i.imgur.com/NAt3CcP.png

I had it fixed by using this in the global.css :
Code:
.post_body > * > img {
    max-width: 100% !important;
}

the second one as to do with the navigation bars. When the width goes below a specific width, they start to mess up (because they're in
Code:
float: right
). See the following shot:

http://i.imgur.com/BKHjFmG.png

the only fix hack I found was to reduce the font size, so that the bug only appear when the browser reach a ridiculous width ^^'

The header should be a bit better now.
I'll figure out a responsive way of making the links and the title appear nice at a certain width.
venam
Here's a clarification tip that should have been posted earlier.
I've noticed a lot of posts that I had to edit because the quote was missing or wrong.

If you are having problem with the "quote" button it's because you are using it the wrong way, probably because it's not intuitive.
To quote someone you overline the text and press quote, it'll quote the text you've chosen.

Cheers!
Can we fix the selection the text? The colors don't match match with the forum default colors.

This code below makes the selection nice looking...

Code:
::selection {
    color: #121212;
    background-color: #484848;
}

Just a suggestion.
venam
(19-09-2015, 11:31 PM)October Wrote: Can we fix the selection the text? The colors don't match match with the forum default colors.

This code below makes the selection nice looking...

Code:
::selection {
    color: #121212;
    background-color: #484848;
}
Just a suggestion.

Fixed
kirby
(11-08-2015, 04:40 AM)venam Wrote: If you are having problem with the "quote" button it's because you are using it the wrong way, probably because it's not intuitive.
To quote someone you overline the text and press quote, it'll quote the text you've chosen.

Could we have it so that pressing the Quote button with nothing highlighted just gets the whole post? While this functionality is cool, it's a tad awkward to highlight everything and as you said, very unintuitive. If it got the whole post with no selection, you could have both.




Members  |  Stats  |  Night Mode  |  Help