IRC - Community & Forums Related Discussions
Thank you z3bra!

For the ii client, it is possible to use UNIX sockets instead of TCP sockets:

# vi /etc/inetd.conf
/tmp/  stream  unix  nowait  nobody  /usr/bin/openssl  openssl s_client -quiet -connect
/tmp/         stream  unix  nowait  nobody  /usr/bin/openssl  openssl s_client -quiet -connect
/tmp/other...          stream  unix  nowait  nobody  /usr/bin/openssl  openssl s_client -quiet -connect irc.other.networks:6697

# ii -s -u /tmp/

And then you have ~/irc/ and not ~/irc/ :)
I have to turn off verification for this server to connect. I'm getting this in weechat:

│13:49:42 | =!= | gnutls: the hostname in the certificate does NOT match ""
│13:49:42 |  -- | gnutls: peer's certificate is trusted
│13:49:42 | =!= | irc: TLS handshake failed
│13:49:42 | =!= | irc: error: Error in the certificate.

For anyone that runs into this, you can turn off verification with:

/set irc.server.<identifier>.ssl_verify off

Members  |  Stats  |  Night Mode  |  Help