Egad! Networking Issues! - Off topic
apk
Hello, all. Thanks for clicking on my thread. As a user here I have noticed that this community of UNIX and Linux users is pretty tight. People know people and you all seem nice. In fact, I've never seen a community like this one.

Anyways on to the problem at hand.
I can't seem to connect to the web. For now I am assuming that the issue is with my /etc/hosts. Heres the scenario:

I am connected via an ethernet cable which is connected directly to my router. My router is my DNS and DHCP servers, so all I need to do is specify 10.0.0.1 (ip of router on network) in whatever the text field might be, and that usually does the trick. Until now!

I am running CRUX 3.0 (new install, all I have done post install wise is add a user) and I followed the handbook when editing /etc/rc.d/net. Here is my file right now

/etc/hosts:
Code:
127.0.0.1    localhost
10.0.0.1   nameserver

I thought resolv.conf was a culprit, but that file has been taken over dhcpcd, so I dont think it is an issue. Any ideas or help? I will supply info if you need it.

Cheers for being cool.
venam
First try a ifconfig to check wether you are connected or not and what are the names of he interfaces.

if resolv.conf is not there create it manually and add : nameserver 208.67.222.222

try changing the hosts file like that:

127.0.0.1 localhost loopback
::1 localhost

hosts is configured in this way:
ipaddr hostname series of aliases

try a "dmesg|grep eth" to check wether the driver is loaded or not.
then lsmod to see if the module is loaded.

what ethernet manager are you using?
if you don't know try to connect manually, without dhcpcd
ip addr add <IP address>/<subnet mask> dev <interface>
ip route add default via <default gateway IP address>

remember that you need to know the subnet mask of the router to put the /<subnet mask>
This is simply done by doing, for example if the subnet is 255.255.192.0
255=1111 1111 ; 8x1
255=1111 1111 ; 8x1
192=1100 0000; 2;1
0 = 0000 0000; 0x1
sum = 8x2 + 2 = 18
so here 255.255.192.0 is equal to /18
subnet is really important to connect to the gateway because otherwise you'll not be considered on the same network.
apk
eth0 does not come up when I execute ifconfig, nor does it come up when I grep dmesg. However an interface called sit0 comes up. Something to do with IPv6-in-IPv4 (to reference ifconfig). Is this possibly a problem with my ethernet cord? Another thing I did was I removed my router's IP address from /hosts, and added loopback and the IPv6 line, like how you showed me in your post, venam.
I don't believe I am running an ethernet manager. I have a very small installation of CRUX. VERY small. Nothing X related AT ALL is installed. Just a set of basic programs and the kernel. I have yet to give manual connection a go, I want to see whats going on with sit0 appearing and not eth0 first.

EDIT: I think this has to do with my kernel config aswell... I'm not a very experienced fella when it comes to configs, so I'll do some research on that, but I feel like that can be something aswell.
venam
Have you tried connecting using the sit0 interface manually?
apk
I fixed the problem by going through my config again. It seems like I was just missing support for my NIC card. Cheers for your help venam and NeoTerra!
apk
Just to add a little PSA/followup, I have a Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller (lspci said so), and there were a couple of options in the kernel menuconfig that related to my card. I don't remeber them specifically, but they were deep in the config. It was Device Support > Network Support > somethingicantrememberoffthetopofmyhead. So, yes, that was indeed the problem. Failure to know what hardware you use before installing is not cool.
A Public Service Announcement from your friendly neighborhood <strike>Spiderman</strike> UNIX user.




Members  |  Stats  |  Night Mode