Installing OpenWRT on the Zipit Z2 for a $20 pocketable linux experience - Other Embedded Platforms and Hardware Hacking
jbeale
I have two stock Zipit Z2 devices, been on a shelf for a few years. I'm trying to follow these instructions. I unzipped FlashStockv01.zip onto a 2 GB uSD card (using a WinXP box) and put that card in a miniSD adaptor into a stock Zipit Z2, and powered it up. It proceeded to give me the stock Z2 intro screens etc. as if the card was not there. I tried SDFormatter, reloaded, retry; same result. The SD card format was FAT. Is there something I'm doing wrong (apart from using windows :-)?
hades
I think it needs to be Ext2 but I'm not sure. Try doing it from linux and also make sure you copy it as root and if it still doesn't work, open a terminal window in linux, navigate to your SD card, and run "sudo chmod +x *" to make sure all the files on the SD card are set as executable.
hades
Update:

Got the Zipit out of storage today, since I haven't messed with it in a couple of years. I have a specific use for it in mind, too: Now I have my own office at work, but my computer sits behind a mess of firewalls and I can't install programs. This means that to monitor IRC channels, I need something small that can sit beneath my monitor and won't take up much space or draw much attention. And so, I'm going to be using the Zipit for that.

But if I'm taking it out of storage and playing with it, why just use it for IRC? I started thinking of other uses it could have, and I remembered that I can't browse 4chan on my work computer - perfect job for the Zipit.

Using a browser that displays images on the Zipit is tedious, so I'll need a sleeker solution - making my own standalone 4chan app. That I will write in Python.

So, I guess this will take the place of my Unix Diary entry for today.

TL;DR - I'm writing a standalone 4chan app for a computer that's slow even by 1998's standards. Fun.




Members  |  Stats  |  Night Mode