RT2571WF WiFi on BSD? - BSD

Users browsing this thread: 1 Guest(s)
Long time nixers
I just got my main computer back up and running with a fresh Dragonfly BSD install (version 3.4.3). I compiled X11 and e17 from source. All of that was done through my Nvidia Ethernet which worked flawlessly. Now I want to get away from the router, so I went to the Freebsd docs and tried to set up my Railink Wifi Antenna.

After following the documentation I went to sbin and tried to get an IP, but it times out and goes to sleep.

So I did a

man -k Railink

and the output says "Railink: Nothing Appropriate".

I also have an external USB WifI antenna, but when I searched for it with pciconf -lv, it was not shown with the other devices listed, nor was the Railink antenna.
The world is quaking from our Linux Thoughts!
Long time nixers
(27-09-2013, 11:36 AM)dcoppa Wrote: It's Ralink, not Railink

:P Oops.

Looking at it correctly now, the OS correctly found my device using

man -k ralink

However Dragonfly (3.4.3) does not have the rum driver in their OS by default. After messing around with the other Ralink drivers they had, none of them worked. So i'll have to download the driver. So i'll post an update on Monday.

Thanks dcoppa for pointing out my spelling mistake, or I would be 90 before I actually figured that out.

Also, if I messed something else up here are the two files I edited.

# /etc/wpa_supplicant.conf

        psk="WPA key"

and my

# /etc/rc.conf

wlan_rum="wlan0"  *wirelress
ifconfig_wlan0="WPA DHCP"  *wireless
ifconfig_nf0="DHCP"  * nvidia ethernet
The world is quaking from our Linux Thoughts!