[SOLVED - FreeBSD] cannot create bootable Linux USB... - BSD

Users browsing this thread: 1 Guest(s)
Long time nixers
To use as a rescue-disk, I needed something able to mount ext4 filesystems. I tried dd-ing the iso image to /dev/da0, but in the end when I try to boot it I just get a black screen with a blinking cursor.

Now the problem is getting bigger, I cannot do anything to the USB. I cannot do -anything- to it. Here's the transcript of my terminal session:

root@mothership:/home/berk # ls /dev/*da*
/dev/ada0    /dev/ada0p2    /dev/ada1s1
/dev/ada0p1    /dev/ada1    /dev/da0
root@mothership:/home/berk # gpart show
=>       34  156301421  ada0  GPT  (74G)
         34        128     1  freebsd-boot  (64k)
        162  155189120     2  freebsd-ufs  (74G)
  155189282    1112173        - free -  (543M)

=>       63  488397105  ada1  MBR  (232G)
         63  488397105     1  linux-data  (232G)

root@mothership:/home/berk # gpart show /dev/da0
gpart: No such geom: /dev/da0.

Losing my mind.
Grey Hair Nixers
gpart create /dev/da0?
Long time nixers
(03-07-2013, 01:14 PM)Beastie Wrote: gpart create /dev/da0?

* berk feels like a noob
Okay, can I safely dd an iso now? It shows up on gpart show.

Edit: when I dd an iso it disappears from gpart show and fdisk says that the partition table is incorrect, etc.
Grey Hair Nixers
dd if=/dev/zero of=/dev/ad0

Then dd the ISO file.