[SOLVED - FreeBSD] cannot mount ext4 partition - BSD
berk
I have a 238.4 GB SAMSUNG HD251HJ ATA-7 SATA2 hard disk which I used as a home partition for my Linux installation. Yesterday I migrated to FreeBSD and I have not been able to recover my data since. I have tried to mount the filesystem, but I keep getting an error. Here's a transcript of my terminal session:

Code:
$ gpart show
=>       34  156301421  ada0  GPT  (74G)
         34        128     1  freebsd-boot  (64k)
        162  155189120     2  freebsd-ufs  (74G)
  155189282    1112173        - free -  (543M)

=>       63  488397105  ada1  MBR  (232G)
         63  488397105     1  linux-data  (232G)

$ du /dev/ada*
0    /dev/ada0
0    /dev/ada0p1
0    /dev/ada0p2
0    /dev/ada1
0    /dev/ada1s1

$ sudo mount /dev/ada1 /mnt/
mount: /dev/ada1: Invalid argument
$ sudo mount /dev/ada1s1 /mnt/
mount: /dev/ada1s1: Invalid argument

Please help me mount /dev/ada1s1, thanks in advance :)
yrmt
There is limited read only support for ext4 filesystems.
You can mount them by:
``# mount -t ext2fs -o ro /dev/name /mountpoint``
venam
Since when BSD is able to mount ext4?
yrmt
You can but in read only mode.
berk
Code:
> sudo mount -t ext2fs -o ro /dev/ada1s1 /mnt
mount: /dev/ada1s1: Invalid argument
> sudo mount -t ext2fs -o ro /dev/ada1 /mnt
mount: /dev/ada1: Invalid argument

Thanks for your answers, but it didn't work. :(
venam
I thought it worked with ext2 in r/w and ext3 in r only.
theconjuring, you can still mount it with a rescue disk.
berk
(03-07-2013, 09:15 AM)venam Wrote: theconjuring, you can still mount it with a rescue disk.

Yes I know I can mount them with a rescue disk, maybe I will need to back them up in a hard disk and reformat it to UFS so FreeBSD plays nicely.

Thanks for the help. :)
yrmt
Oops, I confused ext4 for ext3, sorry.
berk
"rescue disk", I don't have one. I downloaded ttylinux (65 MB) and tried to dd it to an USB, but it doesn't just work. :/

Code:
$ sudo dd if=ttylinux-pc_i686-16.1.iso of=/dev/da0
134764+0 records in
134764+0 records out
68999168 bytes transferred in 466.936130 secs (147770 bytes/sec)

Doesn't boot. :/
venam
Slitaz is also a solution and it comes with a GUI already installed (openbox).




Members  |  Stats  |  Night Mode